Теоретичні відомості

Структура формули

Формули – це вирази, по яких виконуються обчислення. Формула завжди починається із знаку дорівнює (=). Формула може включати функції, посилання на комірки або імена, оператори і константи.

Наприклад, у формулі =СУММ(В2:В8)*30

СУММ() – функція;

В2 і В8 – посилання на комірки;

: (двокрапка) і * (зірочка) – оператори; 30 – константа.

Функції – заздалегідь визначені формули, які виконують обчислення по заданих величинах, що називаються аргументами, і у вказаному порядку. Структура функції: ім’я функції, відкриваюча дужка, список аргументів, розділених крапками з комою, закриваюча дужка. Аргументом функції може бути число, текст, логічне значення, масив, значення помилки, посилання на комірку. Як аргументи використовуються також константи, формули, або функції.

Посилання вказує на комірку або діапазон комірок аркуша, які потрібно використовувати у формулі. Можна задавати посилання на комірки інших листів поточної книги і на інші книги. Посилання на комірки інших книг називаються зв’язками.

Оператором називають знак або символ, що задає тип обчислення у формулі. Існують математичні, логічні оператори, оператори порівняння та посилання.

Константою називають постійне (не обчислюване) значення. Формула і результат обчислення формули не є константами.

Оператори

Арифметичні оператори

Арифметичні оператори служать для виконання арифметичних операцій, таких як додавання, віднімання, множення. Операції виконуються над числами.

Використовуються наступні арифметичні оператори:

ОператорЗначенняПриклад
+ (знак плюс)ДодаванняA1+A2
– (знак мінус)ВідніманняA1‐A2
Заперечення‐A1
* (зірочка)МноженняA1*A2
/ (коса риска)ДіленняA1/A2
% (знак відсотка)Відсоток50%
^ (кришка)Піднесення до ступеняA1^2

Оператори порівняння

Оператори порівняння використовуються для порівняння двох значень. Результатом порівняння є логічне значення: або ІСТИННЕ, або ХИБНЕ.

ОператорЗначенняПриклад
= (знак рівності)Рівно(A1=B1)
> (знак більший)Більше(A1>B1)
< (знак менший)Менше(A1<B1)
>= (знак більше і рівно)Більше або рівно(A1>=B1)
<= (знак менше і рівно)Менше або рівно(A1<=B1)
<> (знак менший і більший)Не рівно(A1<>B1)

Текстовий оператор конкатенації

Текстовий оператор амперсанд (&) використовується для об’єднання декількох текстових значень.

ОператорЗначенняПриклад
& (амперсанд)Об’єднання послідовностей знаків в одну послідовність“Прізвище”&”Ім’я”&”По-

батькові”

Оператори посилань

Оператори посилань використовують для опису посилань на діапазони комірок.

ОператорЗначенняПриклад
: (двокрапка)Ставиться між посиланнями на першу і останню комірку діапазонуB5:B15
;(крапка з комою)Оператор об’єднанняB5:B15;D5:D15
(пропуск)Оператор перетину множин, служить для посилання на загальні комірки двох діапазонівB7:D7 C6:C8

Повна інформація за посиланням: Використання формул і функцій у MS Excel

Допомога студентам з роботами в MS Excel

Форма замовлення

    Вкажіть регіон, в якому знаходиться ваш Вуз
    УкраїнаРосіяЄвропаАмерикаАзія